[patch, libiberty, gdb] IEEE 754 half floating-point format

Joel Brobecker brobecker@adacore.com
Thu Nov 18 17:44:00 GMT 2010


> include/ChangeLog:
> 
> 2010-07-02  Ken Werner  <ken.werner@de.ibm.com>
> 
> 	* gfloatformat.h (floatformat_ieee_half_big): Add declaration.
          ^^^ typo
> 	(floatformat_ieee_half_little): Likewise.
> 
> libiberty/ChangeLog:
> 
> 2010-07-02  Ken Werner  <ken.werner@de.ibm.com>
> 
> 	* floatformat.c (floatformat_ieee_half_big): New variable.
> 	(floatformat_ieee_half_little): Likewise.

This part should be submitted to GCC, I think?

> 2010-07-02  Ken Werner  <ken.werner@de.ibm.com>
> 
> 	* gdbtypes.h (floatformats_ieee_half): Add declaration.
> 	* gdbtypes.c (floatformats_ieee_half): New variable.
> 	* doublest.c (floatformat_from_length): Set format to
> 	gdbarch_half_format if length matches.
> 	* gdbarch.sh (half_bit): New architecture method.
> 	(half_format): Likewise.
> 	* gdbarch.h: Regenerate.
> 	* gdbarch.c: Likewise.

My only comment regarding this part of the patch is that "half_bit"
and "half_format" isn't very intuitive. Perhaps that's more obvious
to someone who programs in OpenCL if "half" is a type name? For
the other arch routines, the routine name makes it clear that it's
about floating point types, because it contains a name that is
clearly associated to floats (float, double, long double).  What
about using "half_float_bit" and "half_float_format"?

What do others think?

-- 
Joel



More information about the Gdb-patches mailing list