[RFA/doc] Redefine the length argument in remote Z packets

Eli Zaretskii eliz@gnu.org
Fri Jan 29 09:00:00 GMT 2010


> Date: Thu, 28 Jan 2010 17:29:41 -0500
> From: Daniel Jacobowitz <dan@codesourcery.com>
> Cc: Eli Zaretskii <eliz@gnu.org>
> 
> I had two options for the new breakpoint.  We could either send
> Z0,ADDR,2 and have the target figure out whether to use the 16-bit or
> 32-bit breakpoint, or we could send Z0,ADDR,3 [number chosen
> arbitrarily] and have the target decide based on that to use a
> 32-bit breakpoint.

Wouldn't it be better to introduce a new packet, say Z32 or some such?

> @@ -28867,7 +28867,8 @@ for an error
>  @cindex @samp{Z} packets
>  Insert (@samp{Z}) or remove (@samp{z}) a @var{type} breakpoint or
>  watchpoint starting at address @var{address} and covering the next
> -@var{length} bytes.
> +@var{length} bytes.  @var{length} may also be a @var{kind} value
> +for breakpoint packets.
>  
>  Each breakpoint and watchpoint packet @var{type} is documented
>  separately.
> @@ -28879,18 +28880,21 @@ remote target shall support either both 
>  avoid potential problems with duplicate packets, the operations should
>  be implemented in an idempotent way.}
>  
> -@item z0,@var{addr},@var{length}
> -@itemx Z0,@var{addr},@var{length}
> +@item z0,@var{addr},@var{kind}
> +@itemx Z0,@var{addr},@var{kind}

You sometimes say that the 2nd arg is a size (but call it "kind") and
sometimes that it's a kind or type.  The above 2 instances are a
typical example.  This is inconsistent and eventually confusing.  I
suggest to use "kind" throughout.

>  Insert (@samp{Z1}) or remove (@samp{z1}) a hardware breakpoint at
> -address @var{addr} of size @var{length}.
> +address @var{addr} of size @var{kind}.

This is one place where it's confusing.

Otherwise, this is fine with me.



More information about the Gdb-patches mailing list