[RFC] Let "gcore" command accept a suffix argument

Tom Tromey tromey@redhat.com
Mon Dec 21 20:15:00 GMT 2009

>>>>> "Stan" == Stan Shebs <stan@codesourcery.com> writes:

Stan> BTW, Pedro nudges me out of my stupor and reminds me that the
Stan> soon-to-be-posted tracepoint action to evaluate without collecting is
Stan> also called "eval" (it was originally proposed as "do" but that
Stan> ambiguates with "down", which seemed like a bad idea).

Stan> The two versions are not necessarily mutually exclusive - the
Stan> downloading at the start of a trace run gives us a chance to filter
Stan> out eval's that don't make sense for the target agent - but if we go
Stan> too afield on syntax (the tracepoint version is simply a
Stan> comma-separated list of GDB expressions), then that's going to be more
Stan> of a problem to reconcile.

"eval" seems awfully generic for a command which is specific to

I'm not super familiar with tracepoints but a lot of the other commands
seem to start with "t".  Why not "teval"?


More information about the Gdb-patches mailing list