[RFA] Refactor bpstat_stop_status.
Mon Dec 17 00:01:00 GMT 2007
On Sun, Dec 16, 2007 at 10:10:28PM +0300, Vladimir Prus wrote:
> * breakpoint.c (check_location)
> (check_watchpoint, check_breakpoint_conditions):
> New, extracted from bpstat_stop_status.
> (bpstat_stop_status): Use the above.
The patch seems fine, but these function names are too generic - they
say what they are checking, but not what they are checking for.
There's already a watchpoint_check which does something different
How about a bp_stop_ prefix? Or anything else that makes it clearer
what they're for.
More information about the Gdb-patches