[RFA] Clarify infrun variable naming.

Vladimir Prus vladimir@codesourcery.com
Wed Dec 5 08:37:00 GMT 2007

On Wednesday 05 December 2007 04:17:52 Jim Blandy wrote:

> - We should rename trap_expected to stepped_over_breakpoint.  The past
>   tense 'stepped' suggests that we're talking about a step which has
>   already happened (which is true by the time we reach
>   handle_inferior_event).

Just like Dan, I find 'stepped' confusing -- we set it before we
actually stepped. I think 'stepping' is fine -- it's set before
we're about to step, and is set until we're done with stepping.

Otherwise, your proposal looks good to me!

- Volodya

More information about the Gdb-patches mailing list