[RFA] Clarify infrun variable naming.

Daniel Jacobowitz drow@false.org
Wed Dec 5 02:47:00 GMT 2007


On Tue, Dec 04, 2007 at 05:17:52PM -0800, Jim Blandy wrote:
> - We should rename trap_expected to stepped_over_breakpoint.  The past
>   tense 'stepped' suggests that we're talking about a step which has
>   already happened (which is true by the time we reach
>   handle_inferior_event).

Don't we set it before we've stepped over the breakpoint?  I find this
a little confusing...

-- 
Daniel Jacobowitz
CodeSourcery



More information about the Gdb-patches mailing list