[commit] Fix info frame's saved registers output
Sun Oct 31 22:44:00 GMT 2004
Eli Zaretskii wrote:
>>Date: Fri, 29 Oct 2004 10:02:09 -0400
>>From: Andrew Cagney <firstname.lastname@example.org>
>>2004-10-27 Andrew Cagney <email@example.com>
>> * trad-frame.c (trad_frame_get_prev_register): Use
>> frame_unwind_register instead of frame_register_unwind
> Isn't it confusing to have 2 different functions whose names are just
> permutations of the same words? How can a GDB hacker know what is the
> difference between frame_register_unwind and frame_unwind_register,
> without reading the sources?
True, wan't to rename it? At the top of frame.h there's a blurb
proposed naming convention.
More information about the Gdb-patches