[rfc/NEWS] GDB works with GCC -feliminate-dwarf2-dups.

Eli Zaretskii eliz@gnu.org
Mon Oct 18 05:01:00 GMT 2004


> Date: Sun, 17 Oct 2004 16:11:43 -0400
> From: Michael Chastain <mec.gnu@mindspring.com>
> Cc: gdb-patches@sources.redhat.com
> 
> Eli, I like this better than my original wording because gdb does
> not actually support versions of gcc; gdb supports certain debug
> formats, which gcc also supports.

I don't understand what you are saying; the original text was:

  * GDB works with GCC -feliminate-dwarf2-dups
  
  GDB now works with programs compiled with -feliminate-dwarf2-dups.
  You must use GCC 3.3.4 or later to use this option.

Where does this say that GDB supports versions of GCC? 

> So about this version?

I'd prefer something like this:

  * GDB works with GCC -feliminate-dwarf2-dups
  
  GDB can now debug programs compiled with the -feliminate-dwarf2-dups
  option to GCC 3.3.4 or later, as well as programs compiled with
  proprietary compilers that produce similar debug information (a more
  compact representation of DWARF-2 debug information using the
  DW_FORM_ref_addr references).

That is what I meant in my previous message: put the user-oriented
information first, and the technicalities after that.



More information about the Gdb-patches mailing list