[RFA/mips] Remove mips16 code that seems redundant
Mon Oct 11 01:16:00 GMT 2004
The block quoted in this patch was moved from mips_insn16_frame_cache()
to there (mips16_heuristic_proc_desc), and I was contemplenting the idea
of merging it the block slightly above in the same function that handles
the case when the first instruction is an entry insn. But then, looking
a bit deeper, it really seems to me that everything done in that block
is already done above. No matter how hard I look, I can't see the catch.
Is there any?
If not, I suggest removing this code. Otherwise, I'll do the merge
I thought about.
2004-10-10 Joel Brobecker <firstname.lastname@example.org>
* mips-tdep.c (mips16_heuristic_proc_desc): Remove redundant code.
What do you think?
More information about the Gdb-patches