[patch, rfa:ppc64, rfa:breakpoint] Add non-verbose breakpoint adjustment

Kevin Buettner kevinb@redhat.com
Tue Oct 28 20:59:00 GMT 2003


On Oct 27, 12:39pm, Andrew Cagney wrote:

> First the "adjust_breakpoint_address" interface is changed so that it 
> returns non-zero if GDB should warn the user of any breakpoint adjustment.

I think this part is fine.  (Don't forget about the docs though.)

> It then modifies breakpoint.c to work with that new interface.  And 
> ppc64 to provide a version of that interface that doesn't require any 
> warning.

And this part too.

> For breakpoint.c, I've also modified the warnings so that the warning:
> 
> warning: Breakpoint 2 address previously adjusted from 0x104e5a60 to 
> 0x100895d0.
> 
> no longer occures - I figure that the user will have noted it when the 
> breakpoint was set.  It could also be made per-breakpoint?

I would prefer that gdb issue warnings both at the time the breakpoint
was set and when it gets hit.  Or at least until we have more
experience with it and find that the second warning unduly annoys
users.

How about calling gdbarch_adjust_breakpoint_address() to find out if
the second warning should be printed?  Alternately, we could add a
field to the breakpoint struct, but this seems like overkill.

Kevin



More information about the Gdb-patches mailing list