[RFA] mips-o64-extract-return-value

Michael Snyder msnyder@redhat.com
Tue Nov 25 22:04:00 GMT 2003


Daniel Jacobowitz wrote:
> On Fri, Nov 21, 2003 at 05:00:57PM -0800, Michael Snyder wrote:
> 
>>Andrew Cagney wrote:
>>
>>>>Right -- I meant *these* changelog entries:
>>>>
>>>>[msnyder@reddwarf gdb]$ grep sysv_abi_return_value ChangeLog
>>>>   * ppc-tdep.h (ppc_sysv_abi_return_value): Ditto.
>>>>   (ppc64_sysv_abi_return_value): Ditto.
>>>>   (ppc_sysv_abi_return_value): Ditto.
>>>>   (ppc64_sysv_abi_return_value): Ditto.
>>>>   * ppc-sysv-tdep.c (ppc_sysv_abi_return_value): New function.
>>>>   * ppc-tdep.h (ppc64_sysv_abi_return_value): Declare.
>>>>   (ppc_sysv_abi_return_value): Declare.
>>>>   (ppc64_sysv_abi_return_value): New function.
>>>>
>>>>
>>>>Sorry, I'm lost.  What's wrong with those ChangeLogs?
>>>>
>>>>s/abi_return_value/abi_store_return_value/g 
>>>
>>>
>>>What?
>>
>>;-)
>>Honest, I didn't mean to make a federal case out of this --
>>your original suggestion to me was to look for a function called
>>"ppc_sysv_abi_return_value".  That function doesn't exist -- but
>>there are several references to it in the changelog.  I eventually
>>figured out that it was missing the word "store_", as in
>>"store_return_value".  So I asked if you'd like me to fix up
>>the change log entries, so they would match the actual function name.
>>
>>Sorry for the confusion...
> 
> 
> Try current CVS?
> 
> ppc-sysv-tdep.c:ppc_sysv_abi_return_value

D'oh, you're right, my bad.  Sorry Andrew -- you must have
thought I was nuts...




More information about the Gdb-patches mailing list