[patch/rfc] Add child_to_xfer_partial; Was: ia64 portion of libunwind patch

Andrew Cagney ac131313@redhat.com
Fri Nov 7 21:40:00 GMT 2003


> I like it because it means I only have to provide the particular functionality instead of overriding the whole function which could be dangerous if other changes were made to the default_xfer_partial routine.

I'ts in.  Any luck with a testcase for the unwind table?  Something to 
add to gdb.arch.  If none of us can figure out a way to tickle this code 
then it may not even be needed.

Kevin wrote ..

> I assume it's #if 0'd because TARGET_OBJECT_UNWIND_TABLE
> isn't defined yet?

Yep.  The intent is to sketch out the mechanism's basic structure.  Jeff 
will enable the code if/when it is needed.

Andrew




More information about the Gdb-patches mailing list