[commit] MAX_REGISTER_VIRTUAL_SIZE -> MAX_REGISTER_SIZE=16

Andrew Cagney ac131313@redhat.com
Thu May 8 18:44:00 GMT 2003


Ref: stupify MAX_REGISTER_{RAW,VIRTUAL}_SIZE
http://sources.redhat.com/ml/gdb/2003-04/msg00014.html

This introduces a new global constant MAX_REGISTER_SIZE and then uses it 
to replace MAX_REGISTER_VIRTUAL_SIZE.  If the current constant value 
(16) turns out to be too small, then someone can make it bigger.

Follow on changes will involve applying a similar:
	s/MAX_REGISTER_RAW_SIZE/MAX_REGISTER_SIZE/
to the core code.  The tdep code will likely end up using 
DEPRECATED_MAX_REGISTER_RAW_SIZE as I don't trust how targets can, 
potentially, be using those "constants".

The really neat thing is that it makes it possible to eliminate so many 
of those alloca()s.

committed,
Andrew
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: diffs
URL: <http://sourceware.org/pipermail/gdb-patches/attachments/20030508/95314f40/attachment.ksh>


More information about the Gdb-patches mailing list