[PATCH] Objective-C language support.

Adam Fedor fedor@doc.com
Mon Oct 14 20:09:00 GMT 2002


Jim Blandy wrote:
> The function stabsread_objc_colon should be static to stabsread.c, no?
> If that's so, then it should be renamed to something like
> `find_name_end', with a comment above the strchr ('[') != 0 case
> explaining its relevance to Objective-C.  Since this function gets
> called on every symbol, it's not an Objective-C specific function;
> only part of it is.
> 
> The code needs a comment.  Most of GDB's maintainers don't know
> Objective-C, so it would be helpful just to say something like,
> "Objective-C symbols can have names like -[foo:bar:baz]:skun

Updated patch:

2002-10-14  Adam Fedor  <fedor@gnu.org>

	* stabsread.c (find_name_end): New function.
	(define_symbol): Use it.




-- 
Adam Fedor, Digital Optics Corp.      | I'm glad I hate spinach, because
http://www.doc.com                    | if I didn't, I'd eat it, and you
                                       | know how I hate the stuff.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: objc5.patch
URL: <http://sourceware.org/pipermail/gdb-patches/attachments/20021014/80454148/attachment.ksh>


More information about the Gdb-patches mailing list