[RFA] Revised C++ ABI abstraction patches

Fernando Nasser fnasser@redhat.com
Thu Mar 15 06:21:00 GMT 2001


What about a configuration option  --with-v3abi (or something of a
sort)?

Default no for 5.1, default on afterwards.

Fernando

Eli Zaretskii wrote:
> 
> On Thu, 15 Mar 2001, Jim Blandy wrote:
> 
> > They're not fit to be applied yet, since we don't yet automatically
> > detect whether the executable uses the V3 or V2 ABI.
> 
> If it's important for users to be able to support the new ABI, you could
> add a command which tells GDB which ABI to expect, no?
> 
> >       * cp-abi-gnu-v2.c (gnu_v2_destructor_prefix_p,
> [...]
> >       (gnu-v3-abi.o): Add.
> >       (gnu-v2-abi.o): Add.
> 
> So what is it: cp-abi-gnu-v2 or gnu-v2-abi?  I prefer the latter, and I
> thought that was the conclusion of the earlier discussions about that.

-- 
Fernando Nasser
Red Hat Canada Ltd.                     E-Mail:  fnasser@redhat.com
2323 Yonge Street, Suite #300
Toronto, Ontario   M4P 2C9



More information about the Gdb-patches mailing list