[PATCH] FreeBSD/i386 ELF support.

Andrew Cagney ac131313@cygnus.com
Wed May 24 18:00:00 GMT 2000


Mark Kettenis wrote:

> GDB won't compile on FreeBSD releases before 2.2 now.  I'll try to fix
> this if I can.  I'll add something to the TODO file if I can't find
> the time to do it within the next week.
> 
> I did my work on FreeBSD 3.4, so I'm not entirely sure if it works
> correctly on other releases.  Testing on other systems would be
> welcome.  Running the testsuite with the system compiler on FreeBSD
> 3.4 (which is gcc 2.7.2.3) gives a lot of warnings, but apparently
> most of these are related to compiler bugs.  Using gcc 2.8.1 from the
> ports collection gives only 25 unexpected failures right now.
> 
> Mark

Thanks!  I've updated the TODO file.  Don't hurry with the <2.2.x stuff.

	Andrew


More information about the Gdb-patches mailing list