RFA: minor watchpoint code cleanup

Eli Zaretskii eliz@delorie.com
Tue Mar 21 10:17:00 GMT 2000


> Yes, yes, but does anyone have comments on my little patch?  :)

Sorry, you are right.

I think this patch is a good idea, but I have one minor suggestion.
Instead of these two lines:

!       size = (len > 4) ? 4 : len;
!       size = size_try_array[size - 1][align];

I would suggest to write this:

	size = size_try_array[len > 4 ? 3 : len - 1][align];

The reason is that IMHO we should avoid making a variable (`size')
serve two puproses at the same time.


More information about the Gdb-patches mailing list