[PATCH] Use proper version of dlltool and windres when cross-compiling

Chris Faylor cgf@cygnus.com
Fri Jun 2 22:03:00 GMT 2000


I've recently applied this patch to configure.in.

cgf

2000-06-02  Christopher Faylor  <cgf@cygnus.com>

        * configure.in: Detect correct versions of dlltoo and windres when
        cross-compiling.
        * configure: Regenerate.

Index: configure.in
===================================================================
RCS file: /cvs/src/src/gdb/configure.in,v
retrieving revision 1.29
diff -u -p -r1.29 configure.in
--- configure.in	2000/05/26 04:11:34	1.29
+++ configure.in	2000/06/03 05:02:26
@@ -78,6 +78,8 @@ AC_PROG_AWK
 AC_PROG_INSTALL
 AC_CHECK_TOOL(AR, ar)
 AC_CHECK_TOOL(RANLIB, ranlib, :)
+AC_CHECK_TOOL(DLLTOOL, dlltool)
+AC_CHECK_TOOL(WINDRES, windres)
 AC_PROG_YACC
 
 dnl MiG is needed for the Hurd.
@@ -606,11 +608,6 @@ AC_CACHE_CHECK([for cygwin], gdb_cv_os_c
 #if defined (__CYGWIN__) || defined (__CYGWIN32__)
 lose
 #endif],[gdb_cv_os_cygwin=yes],[gdb_cv_os_cygwin=no])])
-
-DLLTOOL=${DLLTOOL-dlltool}
-WINDRES=${WINDRES-windres}
-AC_SUBST(DLLTOOL)
-AC_SUBST(WINDRES)
 
 dnl Figure out which term library to use.
 if test x$gdb_host = xgo32; then


More information about the Gdb-patches mailing list