[binutils-gdb] gdb: rename blockvec to rangevec in dwarf2_record_block_ranges

Jan Vrany jv@sourceware.org
Thu Mar 5 23:08:33 GMT 2026


https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=b76de566600dab4d75492a3aded849bf981dcc05

commit b76de566600dab4d75492a3aded849bf981dcc05
Author: Jan Vrany <jan.vrany@labware.com>
Date:   Thu Mar 5 23:07:48 2026 +0000

    gdb: rename blockvec to rangevec in dwarf2_record_block_ranges
    
    This commit just renames local variable blockvec to rangevec. It seems
    to me that rangevec is better name since it holds on struct blockrange.
    
    Approved-By: Tom Tromey <tom@tromey.com>

Diff:
---
 gdb/dwarf2/read.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gdb/dwarf2/read.c b/gdb/dwarf2/read.c
index a6244319f71..287e3f74d7d 100644
--- a/gdb/dwarf2/read.c
+++ b/gdb/dwarf2/read.c
@@ -9363,7 +9363,7 @@ dwarf2_record_block_ranges (struct die_info *die, struct block *block,
 	  if (die->tag != DW_TAG_compile_unit)
 	    ranges_offset += cu->gnu_ranges_base;
 
-	  std::vector<blockrange> blockvec;
+	  std::vector<blockrange> rangevec;
 	  dwarf2_ranges_process (ranges_offset, cu, die->tag,
 				 [&] (unrelocated_addr start,
 				      unrelocated_addr end)
@@ -9371,10 +9371,10 @@ dwarf2_record_block_ranges (struct die_info *die, struct block *block,
 	    CORE_ADDR abs_start = per_objfile->relocate (start);
 	    CORE_ADDR abs_end = per_objfile->relocate (end);
 	    dwarf2_maybe_record_inline_function (cu, block, end);
-	    blockvec.emplace_back (abs_start, abs_end);
+	    rangevec.emplace_back (abs_start, abs_end);
 	  });
 
-	  block->set_ranges (make_blockranges (objfile, blockvec));
+	  block->set_ranges (make_blockranges (objfile, rangevec));
 	}
     }


More information about the Gdb-cvs mailing list