July 2026 Archives by thread
Starting: Wed Jul 1 01:44:59 GMT 2026
Ending: Fri Jul 31 14:50:19 GMT 2026
Messages: 137
- [binutils-gdb] libiberty d_compact_number signed integer overflow
Alan Modra
- [binutils-gdb] Do not write negative PID or TID in remote protocol
Tom Tromey
- [binutils-gdb] Fix ptid_t selftest crash
Tom Tromey
- [binutils-gdb] Handle -1 in ptid_t::parse
Tom Tromey
- [binutils-gdb] gdb/testsuite: deduplicate --offload-arch targets in hcc_amdgpu_targets
Luis Machado
- [binutils-gdb] gdb: replace alloca with gdb::unique_xmalloc_ptr in remote-fileio.c
Luis Machado
- [binutils-gdb] gdb/testsuite: fix gdb.rocm/interrupt-twice
Lancelot SIX
- [binutils-gdb] gdb, amd-dbgapi-target: use pulongest to print id handles
Tankut Baris Aktemur
- [binutils-gdb] gdb/record: Refactor record history
Guinevere Larsen
- [binutils-gdb] gdb/record: factor out reading and writing the execution log to corefile
Guinevere Larsen
- [binutils-gdb] gdb/record: remove record_full_insn_num
Guinevere Larsen
- [binutils-gdb] gdb/record: c++ify internal structures of record-full.c
Guinevere Larsen
- [binutils-gdb] gdb/record: make record_full_history more c++-like
Guinevere Larsen
- [binutils-gdb] gdb/record: extract the PC to record_full_instruction
Guinevere Larsen
- [binutils-gdb] gdb/record: Define new version of the record-save section
Guinevere Larsen
- [binutils-gdb] gdb/record: rename record_full_list to record_full_log
Guinevere Larsen
- [binutils-gdb] gdb/record: Add support for recording BMI1 instructions
Guinevere Larsen
- [binutils-gdb] gdb/record: add support for BMI2 instructions
Guinevere Larsen
- [binutils-gdb] gdb, amd-dbgapi-target: use pulongest more
Tankut Baris Aktemur
- [binutils-gdb] gdb, amd-dbgapi-target: split wave_coordinates::to_string
Tankut Baris Aktemur
- [binutils-gdb] s390: Deprecate s390 32-bit target "s390-*"
Jens Remus
- [binutils-gdb] gdb/record-full: fix some -Wpessimizing-move errors
Simon Marchi
- [binutils-gdb] Windows: Normalize backslashes to forward slashes
Pedro Alves
- [binutils-gdb] gdb.rocm/multi-inferior-gpu.exp: Use allow_fork_tests
Pedro Alves
- [binutils-gdb] gdb.rocm: Don't include unistd.h when not necessary
Pedro Alves
- [binutils-gdb] Windows/rocm-solib: Don't hardcode namespaces support
Pedro Alves
- [binutils-gdb] gdb/record-full: make record_full_arch_list_add take an rvalue ref
Simon Marchi
- [binutils-gdb] regdat.sh: generate const_target_desc_up for register descriptions
Keith Seitz
- [binutils-gdb] [gdbserver] Use const_target_desc_up for regformat tdescs
Keith Seitz
- [binutils-gdb] gdb/testsuite: don't overwrite test executable in py-frame.exp
Andrew Burgess
- [binutils-gdb] gdb/python: remove frame_object::frame_id_is_next as unnecessary
Andrew Burgess
- [binutils-gdb] gdb, amd-dbgapi-target: fix extra space in wave_coordinates
Tankut Baris Aktemur
- [binutils-gdb] gdb: z80: Fix endless loop in frame unwinder and validate saved register types
Kevin Buettner
- [binutils-gdb] gdb/hip: Prepare for DWARF-assembler-based HIP testcases
Pedro Alves
- [binutils-gdb] gdb.base/execl-update-breakpoints.exp: Don't execl forever
Pedro Alves
- [binutils-gdb] gdb/linux-tdep: change linux_fill_prpsinfo to return bool
Matthieu Longo
- [binutils-gdb] Created branch 'binutils-2_47-branch'
Nick Clifton
- [binutils-gdb] [gdb/testsuite] Fix isort fail in gdb.python/py-frame.py
Tom de Vries
- [binutils-gdb] [pre-commit] Bump isort to 9.0.0b1
Tom de Vries
- [binutils-gdb] [pre-commit] Remove duplication in config file
Tom de Vries
- [binutils-gdb] [gdb] Move ChangeLog files to archive dir
Tom de Vries
- [binutils-gdb] [gdb] Use using instead of typedef some more (part 1)
Tom de Vries
- [binutils-gdb] [gdb] Use using instead of typedef some more (part 2)
Tom de Vries
- [binutils-gdb] [gdb] Use using instead of typedef some more (part 3)
Tom de Vries
- [binutils-gdb] [gdb] Convert function pointer typedefs to using
Tom de Vries
- [binutils-gdb] [gdb] Convert template typedefs to using
Tom de Vries
- [binutils-gdb] [gdb] Convert function typedefs to using
Tom de Vries
- [binutils-gdb] [gdb] Fix redundant struct typedefs
Tom de Vries
- [binutils-gdb] [gdb] Convert anonymous struct typedefs
Tom de Vries
- [binutils-gdb] [gdb] Convert typedef of named struct
Tom de Vries
- [binutils-gdb] [gdb] convert struct pointer typedefs
Tom de Vries
- [binutils-gdb] [gdb] Convert typedef on separate line
Tom de Vries
- [binutils-gdb] [gdb] Use using in compat_x32_clock_t typedef
Tom de Vries
- [binutils-gdb] [gdb] More codespell fixes
Tom de Vries
- [binutils-gdb] [gdb/testsuite] Fix FAIL in gdb.threads/sw-watchpoint-step-over-bp-with-threads.exp
Tom de Vries
- [binutils-gdb] [gdb/exp] Limit workaround in using_direct::valid_line to broken GCC versions
Tom de Vries
- [binutils-gdb] [gdb/exp] Fix ns var lookup when stopped at inlined fn call
Tom de Vries
- [binutils-gdb] [gdb] Break up complex assignment in cp_lookup_symbol_via_imports
Tom de Vries
- [binutils-gdb] [gdb/exp] Fix ignoring of incorrect namespace prefix
Tom de Vries
- [binutils-gdb] [gdb/exp] Handle recursive namespace import
Tom de Vries
- [binutils-gdb] [pre-commit] Bump codespell to v2.4.3
Tom de Vries
- [binutils-gdb] Document remote protocol pid and thread id sizes
Tom Tromey
- [binutils-gdb] Use bool in ada_type_of_array
Tom Tromey
- [binutils-gdb] [pre-commit] Fix codespell-log hook
Tom de Vries
- [binutils-gdb] [gdb] Fix hard-coded constants in buildsym_compunit::make_blockvector
Tom de Vries
- [binutils-gdb] Handle missing array descriptor in ada_type_of_array
Tom Tromey
- [binutils-gdb] Assume an unrecognized gnatmake is very new
Tom Tromey
- [binutils-gdb] [gdb] Add default argument for get_selected_block
Tom de Vries
- [binutils-gdb] gdb: add annotation in 'info locals' command for variables shadowing case
Abdul Basit Ijaz
- [binutils-gdb] gdb: add shadowed field in '-stack-list-locals/variables' mi commands
Abdul Basit Ijaz
- [binutils-gdb] [gdb/testsuite] Fix check-file-mode errors
Tom de Vries
- [binutils-gdb] [gdb/testsuite] Fix tclint errors
Tom de Vries
- [binutils-gdb] [pre-commit] Set stages for isort
Tom de Vries
- [binutils-gdb] gdb: LoongArch: Add internal TLS support
Tiezhu Yang
- [binutils-gdb] gdb: recreate the frame_info_ptr in get_prev_frame_maybe_check_cycle
Andrew Burgess
- [binutils-gdb] gdb/tui: fix unexpected reuse of color pairs
Andrew Burgess
- [binutils-gdb] [gdb/testsuite] Improve gdb.src/pre-commit.exp
Tom de Vries
- [binutils-gdb] gdb.base/nodebug.exp: Disable -Wdeprecated-non-prototype
Pedro Alves
- [binutils-gdb] gdb.base/nodebug.exp: Add long double testing
Pedro Alves
- [binutils-gdb] gdb.base/callfuncs.exp: Adjust for Windows
Pedro Alves
- [binutils-gdb] gdb.base/callfuncs.c: factor out float/double functions
Pedro Alves
- [binutils-gdb] gdb.base/callfuncs.exp: Exercise "long double"
Pedro Alves
- [binutils-gdb] gdb/Windows testsuite: Embed asInvoker manifest in test executables
Pedro Alves
- [binutils-gdb] Windows: Fix set_unbuffered_mode.o file rename race
Pedro Alves
- [binutils-gdb] gdb/testsuite: Use file_rename_atomic in gdb_do_cache too
Pedro Alves
- [binutils-gdb] Use bool in continue_1
Tom Tromey
- [binutils-gdb] Remove for_each_thread
Tom Tromey
- [binutils-gdb] GDB: aarch64: Fix inferior function call if GCS is present but disabled
Thiago Bauermann
- [binutils-gdb] Export SHELL before invoking lineno.sh
Tom Tromey
- [binutils-gdb/gdb-17-branch] GDB: aarch64: Fix inferior function call if GCS is present but disabled
Thiago Bauermann
- [binutils-gdb] gdb: fix maint info btrace
Markus Metzger
- [binutils-gdb] gdb: use type instance macros to query const, volatile, restrict
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert address_class_type_flags_to_name to address_class_id_to_name
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert address_class_name_to_type_flags to address_class_name_to_id
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert address_class_type_flags to address_class_dwarf_to_id
Tankut Baris Aktemur
- [binutils-gdb] gdb: refactor type_stack::insert methods
Tankut Baris Aktemur
- [binutils-gdb] gdb: inline address_space_{name, type_instance_flags}_to_{type_instance_flags, name}
Tankut Baris Aktemur
- [binutils-gdb] gdb: split make_type_with_address_space
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert type instance flags to bitfields
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_NOTTEXT macro to type::is_nottext
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_CONST macro to type::is_const
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_VOLATILE macro to type::is_volatile
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_CODE_SPACE macro to type::is_code_space
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_DATA_SPACE macro to type::is_data_space
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_RESTRICT macro to type::is_restrict
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_ATOMIC macro to type::is_atomic
Tankut Baris Aktemur
- [binutils-gdb] gdb: convert TYPE_ADDRESS_CLASS macro to type::address_class
Tankut Baris Aktemur
- [binutils-gdb] gdb: remove unnecessary braces in recursive_dump_type
Tankut Baris Aktemur
- [binutils-gdb] gdb/MAINTAINERS: update my name
Christina Schimpe
- [binutils-gdb] Remove some "stabsread" references
Tom Tromey
- [binutils-gdb] gdb/testsuite: missing ';' in check-all-boards rule
Andrew Burgess
- [binutils-gdb] gdb/testsuite: fix shellcheck issues in make-check-all.sh
Andrew Burgess
- [binutils-gdb] gdb/testsuite: improve rerun scripts generated by make-check-all.sh
Andrew Burgess
- [binutils-gdb] Simplify ada_parse_renaming
Tom Tromey
- [binutils-gdb] gdb, testsuite: fix typo "skippig"
Tankut Baris Aktemur
- [binutils-gdb] [gdb/testsuite] Fix timeout in gdb.threads/vfork-multi-inferior.exp
Tom de Vries
- [binutils-gdb] [gdb/testsuite] Fix race in gdb.threads/leader-exit.exp
Tom de Vries
- [binutils-gdb] [gdb/contrib] Add skippig->skipping to codespell-dictionary.txt
Tom de Vries
- [binutils-gdb/binutils-2_47-branch] This is the 2.47 release
Nick Clifton
- [binutils-gdb] Created tag 'binutils-2_47'
Nick Clifton
- [binutils-gdb] gdb.rocm/watchpoint-basic: use gdb_continue_to_end
Shahab Vahedi
- [binutils-gdb] gdb.rocm/watchpoint-basic: add XFAILs for known configurations
Shahab Vahedi
- [binutils-gdb] gdb/tui: convert a window handle `if` into an `assert`
Andrew Burgess
- [binutils-gdb] gdb/testsuite: fix tuiterm linefeed scrolling new line content
Andrew Burgess
- [binutils-gdb] gdb/tui: prevent TUI activation from a secondary prompt
Andrew Burgess
- [binutils-gdb] gdb/tui: make tui_win_info::rerender public
Andrew Burgess
- [binutils-gdb] gdb/tui: fix for debuginfod prompt while enabling the TUI
Andrew Burgess
- [binutils-gdb] gdb/tui: fix debuginfod prompt using 'C-x C-a' to enter TUI
Andrew Burgess
- [binutils-gdb] [gdb/testsuite] Fix codespell errors in gdb.tui/debuginfod-query.exp
Tom de Vries
- [binutils-gdb] [pre-commit] Fix yamllint errors in .pre-commit-config.yaml
Tom de Vries
- [binutils-gdb] [pre-commit] Add yamllint hook
Tom de Vries
- [binutils-gdb] [pre-commit] add 'tomli' dependency for codespell pre-commit hook
Tom de Vries
- [binutils-gdb] PowerPC: Fix compile command by reverting to default code model
Abhay Kandpal
- [binutils-gdb] gdb, dwarf: update code style in read_tag_pointer_type
Tankut Baris Aktemur
- [binutils-gdb] gdb, dwarf: update complaint logic in read_tag_pointer_type
Tankut Baris Aktemur
- [binutils-gdb/gdb-17-branch] gdb/tui: Fix build for older ncurses
Ciaran Woodward
- [binutils-gdb] [gdb/testsuite] Fix gdb.python/py-finish-breakpoint-tailcall.exp with gcc 16
Tom de Vries
Last message date:
Fri Jul 31 14:50:19 GMT 2026
Archived on: Fri Jul 31 14:50:20 GMT 2026
This archive was generated by
Pipermail 0.09 (Mailman edition).