[binutils-gdb] gdb/fortran: rename f77_keywords to f_keywords
Nils-Christian Kempke
nckempke@sourceware.org
Mon Apr 11 12:09:09 GMT 2022
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=04ba65365054e37461b4fd904ff9c00d88023b02
commit 04ba65365054e37461b4fd904ff9c00d88023b02
Author: Nils-Christian Kempke <nils-christian.kempke@intel.com>
Date: Mon Apr 11 14:06:56 2022 +0200
gdb/fortran: rename f77_keywords to f_keywords
Rename f77_keywords to f_keywords since some of the introduced keywords
in the array are f90 only.
Diff:
---
gdb/f-exp.y | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/gdb/f-exp.y b/gdb/f-exp.y
index bb8e2ba6475..3ef44eca992 100644
--- a/gdb/f-exp.y
+++ b/gdb/f-exp.y
@@ -1138,7 +1138,7 @@ static const struct f77_boolean_val boolean_values[] =
{ ".false.", 0 }
};
-static const struct token f77_keywords[] =
+static const token f_keywords[] =
{
/* Historically these have always been lowercase only in GDB. */
{ "character", CHARACTER, OP_NULL, true },
@@ -1473,7 +1473,7 @@ yylex (void)
/* Catch specific keywords. */
- for (const auto &keyword : f77_keywords)
+ for (const auto &keyword : f_keywords)
if (strlen (keyword.oper) == namelen
&& ((!keyword.case_sensitive
&& strncasecmp (tokstart, keyword.oper, namelen) == 0)
More information about the Gdb-cvs
mailing list