[binutils-gdb] sim: common: rename sim_print_config
Michael Frysinger
vapier@sourceware.org
Mon Jan 4 22:35:36 GMT 2021
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=dbed468bcb8dc3c85fcf30ebae7ba67cbe7dc19c
commit dbed468bcb8dc3c85fcf30ebae7ba67cbe7dc19c
Author: Mike Frysinger <vapier@gentoo.org>
Date: Sun Jan 3 19:10:49 2016 -0500
sim: common: rename sim_print_config
print_sim_config has never been used anywhere, so rename it to follow
the sim_* naming style for all other symbols we export.
Diff:
---
sim/common/ChangeLog | 6 ++++++
sim/common/sim-config.c | 2 +-
sim/common/sim-config.h | 2 +-
3 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/sim/common/ChangeLog b/sim/common/ChangeLog
index 0545493f571..e815aeafd65 100644
--- a/sim/common/ChangeLog
+++ b/sim/common/ChangeLog
@@ -1,3 +1,9 @@
+2021-01-04 Mike Frysinger <vapier@gentoo.org>
+
+ * sim-config.c (print_sim_config): Rename to ...
+ (sim_print_config): ... this.
+ * sim-config.h: Likewise.
+
2021-01-02 Mike Frysinger <vapier@gentoo.org>
* sim-bits.h (_ALIGNa, _FLOORa, ALIGN_8, ALIGN_16, ALIGN_PAGE,
diff --git a/sim/common/sim-config.c b/sim/common/sim-config.c
index ba3e372c159..59ee2d8f322 100644
--- a/sim/common/sim-config.c
+++ b/sim/common/sim-config.c
@@ -294,7 +294,7 @@ sim_config (SIM_DESC sd)
void
-print_sim_config (SIM_DESC sd)
+sim_print_config (SIM_DESC sd)
{
sim_io_printf (sd, "WITH_TARGET_BYTE_ORDER = %s\n",
config_byte_order_to_a (WITH_TARGET_BYTE_ORDER));
diff --git a/sim/common/sim-config.h b/sim/common/sim-config.h
index 8e70bc8210b..43c0327fd52 100644
--- a/sim/common/sim-config.h
+++ b/sim/common/sim-config.h
@@ -313,7 +313,7 @@ extern SIM_RC sim_config (SIM_DESC sd);
/* Print the simulator configuration. */
-extern void print_sim_config (SIM_DESC sd);
+extern void sim_print_config (SIM_DESC sd);
#endif
More information about the Gdb-cvs
mailing list