gdb and binutils branch master updated. ee01b6652ad55437e777fb7e6b1745782dc205a4

brobecke@sourceware.org brobecke@sourceware.org
Mon Feb 10 14:05:00 GMT 2014


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  ee01b6652ad55437e777fb7e6b1745782dc205a4 (commit)
      from  143adbbfa31d98b59c0a1509ac3819cc64b241c8 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=ee01b6652ad55437e777fb7e6b1745782dc205a4

commit ee01b6652ad55437e777fb7e6b1745782dc205a4
Author: Joel Brobecker <brobecker@adacore.com>
Date:   Mon Feb 10 17:49:27 2014 +0400

    [Ada] Make the symbol cache per-program-space.
    
    This patch moves the Ada symbol cache to per-program-space data.
    
    gdb/ChangeLog:
    
            * ada-lang.c (struct cache_entry, HASH_SIZE): Move definition up.
            (struct ada_symbol_cache): New.
            (ada_free_symbol_cache): Forward declare.
            (struct ada_pspace_data): New.
            (ada_pspace_data_handle): New static global.
            (get_ada_pspace_data, ada_pspace_data_cleanup)
            (ada_init_symbol_cache, ada_free_symbol_cache): New functions.
            (cache_space, cache): Delete, now folded inside struct
            ada_pspace_data.
            (ada_get_symbol_cache): New function.
            (ada_clear_symbol_cache, find_entry, cache_symbol): Adjust
            implementation.
            (_initialize_ada_language): Remove initialization of cache_space.
            Move call to observer_attach_inferior_exit up, grouping it
            with the other observer registrations inside this function.
            Rename command to be more general.  Add call to
            register_program_space_data_with_cleanup.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog  |   20 +++++++
 gdb/ada-lang.c |  174 +++++++++++++++++++++++++++++++++++++++++++-------------
 2 files changed, 154 insertions(+), 40 deletions(-)


hooks/post-receive
-- 
gdb and binutils



More information about the Gdb-cvs mailing list