src/gdb ChangeLog ada-lang.c ada-lang.h ada-ta ...
hilfingr@sourceware.org
hilfingr@sourceware.org
Wed Jun 16 08:18:00 GMT 2004
CVSROOT: /cvs/src
Module name: src
Changes by: hilfingr@sourceware.org 2004-06-16 08:18:06
Modified files:
gdb : ChangeLog ada-lang.c ada-lang.h ada-tasks.c
Log message:
* ada-tasks.c: Rename build_task_list to ada_build_task_list, and
make it non-static.
* ada-lang.h (task_control_block): declaration moved from ada-task.c
to ada-lang.h; this is needed to be able to implement the kill command
in multi-task mode.
(task_ptid): Ditto.
(task_entry): Ditto.
(task_list): Ditto.
(ada_build_task_list): Ditto.
* ada-lang.c: Conditionalize routines and data structures related
to breakpoints, exceptions, completion, and symbol caching on
GNAT_GDB, since these are not yet used in the submitted public sources.
(ada_main_name): Editorial: Move definition out of exception-related
code.
Patches:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/ChangeLog.diff?cvsroot=src&r1=1.6012&r2=1.6013
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/ada-lang.c.diff?cvsroot=src&r1=1.37&r2=1.38
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/ada-lang.h.diff?cvsroot=src&r1=1.8&r2=1.9
http://sources.redhat.com/cgi-bin/cvsweb.cgi/src/gdb/ada-tasks.c.diff?cvsroot=src&r1=1.9&r2=1.10
More information about the Gdb-cvs
mailing list