Problems with the GNU linker....

Koundinya.K kk@ddeorg.soft.net
Tue Jan 5 03:17:00 GMT 1999


Hi all,
	I have been using the egcs-2.91.57 19980901 (egcs-1.1 release) gcc and g++ 
compilers and all the other tools on my system which is MIPS (R4000) based 
running the SVR4.2 UNIX on the Supermax Business Server for a few months now 
and they seem to work fine.

	How ever I am still not able to use the GNU linker. For making the egcs 
port I used the native linker ( from the EPC - Edinberg portable compiler 
and Tools) and it took me 6 months !!. I am not able to generate the dynamic 
libraries. The GNU assembler (gas) and the native ld pair does not seem to 
work.

So again I decided to try making the latest ld from the most recent 
snapshots from ftp.cygnus.com/private/gas.

For getting the ld compiled I used the following in the ld/configure.tgt as 
before.

	mips-*-sysv*)           targ_emul=elf32bsmip ;;

Got the ld compiled. But when I try to compile the famous Hello world 
program I get

	
--------------- Output of test --------------------------------------------
../test
Hello World
dynamic linker: ./test: unidentifiable procedure reference (address = 
0x40062cd8)
Killed

-----------------------------------------------------------------------------
-

I tried to use the readelf utility , but got no clues.

The ldd -d ./test shows that that the C libraries are dynamically loaded.

Is the support for the GNU linker on most of the MIPS platforms still not 
complete. ? Is this a known problem ?. Please help me. Are there any patches 
available ?.


Thanks a lot for any help received.

With best regards

Koundinya








More information about the Gas2 mailing list