[PATCH v3 3/3] libdwfl: switch to DEBUGINFOD_SONAME, remove libdebuginfod.so fallback

Mark Wielaard mark@klomp.org
Wed Dec 9 22:43:20 GMT 2020

On Wed, 2020-12-09 at 03:13 +0300, Dmitry V. Levin wrote:
> Since DEBUGINFOD_SONAME is as good as ("libdebuginfod-" VERSION ".so")
> for dlopen, switch to use the name which is a part of the API.
> Given that DEBUGINFOD_SONAME is always available now, remove the no longer
> needed fall back to dlopen of "libdebuginfod.so".




More information about the Elfutils-devel mailing list