Buildbot failure in Wildebeest Builder on whole buildset

Mark Wielaard mark@klomp.org
Mon Mar 23 14:08:03 GMT 2020


Hi,

On Mon, 2020-03-23 at 13:38 +0000, buildbot@builder.wildebeest.org
wrote:
> The Buildbot has detected a failed build on builder whole buildset
> while building elfutils.
> Full details are available at:
>     https://builder.wildebeest.org/buildbot/#builders/4/builds/492
> 
> Buildbot URL: https://builder.wildebeest.org/buildbot/
> 
> Worker for this Build: debian-i386
> [...]
> Full details are available at:
>     https://builder.wildebeest.org/buildbot/#builders/15/builds/288
> 
> Buildbot URL: https://builder.wildebeest.org/buildbot/
> 
> Worker for this Build: debian-armhf

Well, that is odd. Both are 32bit arches. The failure is the same in
run-lfs-symbols.sh

   FAIL: run-lfs-symbols.sh
   ========================
   ./testfile-nolfs contains non-lfs symbols: fopen
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_i386.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_sh.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_x86_64.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_ia64.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_alpha.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_arm.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_aarch64.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_sparc.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_ppc.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_ppc64.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_s390.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_tilegx.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_m68k.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_bpf.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_riscv.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/src/nm: cannot open
   '/srv/buildbot/worker/elfutils-debian-
   i386/build/backends/libebl_csky.so': No such file or directory
   /srv/buildbot/worker/elfutils-debian-i386/build/tests/getphdrnum
   contains non-lfs symbols: open
   FAIL run-lfs-symbols.sh (exit status: 1)

The backends shared libraries don't exist anymore and should be removed
from the testcase.

But I don't immediately see what/where I forgot which flags to make the
new getphdrnum check program picks up the wrong "open".

Investigating...

Mark


More information about the Elfutils-devel mailing list