(lfedora1) Re: Buildbot failure in Wildebeest Builder on whole buildset

Mark Wielaard mark@klomp.org
Thu Aug 15 09:46:00 GMT 2019


On Thu, Aug 15, 2019 at 08:28:25AM +0000, buildbot@builder.wildebeest.org wrote:
> The Buildbot has detected a failed build on builder whole buildset
> while building elfutils.
>
> Full details are available at:
>     https://builder.wildebeest.org/buildbot/#builders/10/builds/349
> 
> Buildbot URL: https://builder.wildebeest.org/buildbot/
> 
> Worker for this Build: fedora-s390x

Given that the last change didn't actually change any actual code,
this is odd. The output looks truncated.

Looking at the host (lfedora1) there seems to be something wrong.
dmesg contains a large number of the following messages:

[2900702.819859] User process fault: interruption code 0006 ilc:1 
[2900702.819873] CPU: 1 PID: 27760 Comm: ld64.so.1 Not tainted 5.0.16-200.fc29.s390x #1
[2900702.819875] Hardware name: IBM 2964 NE1 716 (z/VM 6.4.0)
[2900702.819878] User PSW : 0705100180000000 0018b72fb1511695
[2900702.819880]            R:0 T:1 IO:1 EX:1 Key:0 M:1 W:0 P:1 AS:0 CC:1 PM:0 RI:0 EA:3
[2900702.819883] User GPRS: ffffffff00000000 0018b72fb1511693 0000000000000001 000003fffb47e990
[2900702.819886]            0000000000000000 0000000000000000 000003fffb47e990 000003ffa9aaa2a0
[2900702.819888]            000003ff0003a2f8 0000000000000000 000003fffb47e990 0000000000000001
[2900702.819891]            000003fffb47eb98 000003fffb47f0e0 000003ffa8104518 000003fffb47e830
[2900702.819897] User Code: Bad PSW.
[2900702.819900] Last Breaking-Event-Address:
[2900702.819906]  [<000003ffa8104516>] 0x3ffa8104516

The last few builds on lfedora1 also took way longer than usual.
https://builder.wildebeest.org/buildbot/#/builders/10
It used to take 30~40 minutes, but now it takes 3~4 hours...

I wonder if something is wrong with the s390x build host.

Thanks,

Mark



More information about the Elfutils-devel mailing list