[Bug general/23977] make check fails run-ar.sh in versions 0.173-0.175

mark at klomp dot org sourceware-bugzilla@sourceware.org
Tue Dec 25 13:20:00 GMT 2018


Mark Wielaard <mark at klomp dot org> changed:

           What    |Removed                     |Added
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|---                         |WORKSFORME

--- Comment #5 from Mark Wielaard <mark at klomp dot org> ---
(In reply to Rashawn from comment #4)
> I did build onto the machine's local file system and encountered the same
> error. I then went back and read through all of the configure options listed
> via ./configure --help. I notice, in addition to --prefix, the
> --enable-deterministic-archives might be worth trying as it is the only
> option which mentions anything about archives, and based on the binutils
> description of -D regarding setting uid and guids to zero it made sense
> because the make check error complained about ar_uid. This worked, and I was
> able to install the latest version 0.175 into the NFS allocation as
> originally planned. 
> My configure line using GCC 8.0.2 ended up like this: ./configure
> --prefix=$eupref --enable-deterministic-archives CC=gcc 2>&1 | tee
> ../build-out-files/2018_1212_elfutils-0.175_gcc-8.2.0_configure-01.out.
> Thank you for your input and advice. I am happy to have this solved.

I am somewhat surprised that this worked around the issue. But happy there is a
workaround. Lets close this for now. Thank for experimenting.

You are receiving this mail because:
You are on the CC list for the bug.

More information about the Elfutils-devel mailing list