[Bug general/23977] make check fails run-ar.sh in versions 0.173-0.175

knappr2 at earthlink dot net sourceware-bugzilla@sourceware.org
Wed Dec 12 21:25:00 GMT 2018


--- Comment #4 from Rashawn <knappr2 at earthlink dot net> ---
(In reply to Mark Wielaard from comment #3)
> Comment on attachment 11451 [details]
> test-suite.log
> It looks like the file we want to put into the ar has a numeric uid that
> cannot be represented in the ar header. I am not sure yet how that could
> happen.
> Does it work if you do the build and run the test not on an nfs file system?

Hello Mark and others,

I did build onto the machine's local file system and encountered the same
error. I then went back and read through all of the configure options listed
via ./configure --help. I notice, in addition to --prefix, the
--enable-deterministic-archives might be worth trying as it is the only option
which mentions anything about archives, and based on the binutils description
of -D regarding setting uid and guids to zero it made sense because the make
check error complained about ar_uid. This worked, and I was able to install the
latest version 0.175 into the NFS allocation as originally planned. 

My configure line using GCC 8.0.2 ended up like this: ./configure
--prefix=$eupref --enable-deterministic-archives CC=gcc 2>&1 | tee

Thank you for your input and advice. I am happy to have this solved.



You are receiving this mail because:
You are on the CC list for the bug.

More information about the Elfutils-devel mailing list