[ECOS] Using Lwip 1.3.2 port of Ecos 3.0 on Ecos 2.0

Fred39 haydar.oezel@web.de
Mon May 28 08:29:00 GMT 2012


Hello everyone

we are using Ecos 2.0 on a At91rm9200 Chip. The only reason we use Ecos 2.0
is that the template what we have for this controller only works with the
2.0 version of Ecos.

So we are trying to get the lwip port of ecos 3.0 work on the ecos 2.0. The
lwip stack for the ecos 2.0 is version 0.7 I guess and its very old.
We can ping to our device which is a great accomplishment :) But we want to
use the new lwip stack 1.3.2 but there is only a port for ecos 3.0.
I tried to use the newer LWIP 1.3.2 stack with the port for ecos 3.0 on Ecos
2.0 but it doesn’t work. What happens is that the function tcpip_init_done
never returns and the lwip stack does not initialize.

With the old LWIP stack i tried the tcpecho example but i get a connection
error "not possible to connect to port 23" 
Examples which are using the raw api are working fine, but examples which
are using the netconn or socket api are not running. I guess it’s because
the stack is a very old one. Thats one of the main reasons why we want to
use the newer lwip stack 1.3.2 and also this newer version supports more
network protocols.

So my Question is how can i use the Ecos 3.0 port of the LWIP stack 1.3.2 on
our Ecos 2.0 version.

Just replacing the old lwip stack with the newer one and replacing the
eth_drv.c of ecos 2.0 with the eth_drv.c of the ecos 3.0 ? 

Where can i start to change the code to use the newer port on ecos 2.0 ?
What have to be considered?
Is it even possible to do that?

Would be really thankful of any advice

Regards

-- 
View this message in context: http://old.nabble.com/Using-Lwip-1.3.2-port-of-Ecos-3.0-on-Ecos-2.0-tp33918491p33918491.html
Sent from the Sourceware - ecos-discuss mailing list archive at Nabble.com.


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list