[ECOS] Re: simple redboot package donot build for i386!

John Dallaway john@dallaway.org.uk
Fri May 4 07:46:00 GMT 2012


Abhishek

abhishek srivastava wrote:

> it seems that in my last post i was not clear with my question so no one responded !
> just repeating the question with detailed error
> 
> i am trying to generate package "redboot" for i386 (vmware) hardware.
> i have also imported "redboot_FLOOPY.ecm", made no change and tried to build library.
> i got error !!! why?

The error you are seeing may be just an issue with your current build
tree. Try giving your .ecc file a new name ("File->Save As..") and then
building the new configuration.

Once you have overcome the above issue, you will find that you need to
use the current lancepci ethernet driver sources from CVS when building
with i386-elf-gcc 4.3.2. Ref:

http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/packages/devs/eth/amd/lancepci/current/src/if_lancepci.c.diff?r1=1.3&r2=1.4&cvsroot=ecos

I hope this helps...

John Dallaway
eCos maintainer
http://www.dallaway.org.uk/john

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list