[ECOS]Redboot for FSL TWRK70F120M with Linux kernel booting

Ilija Kocho ilijak@siva.com.mk
Wed Mar 14 07:44:00 GMT 2012


Hi Linh



On 14.03.2012 05:39, Linh Nguyá»
n wrote:
> Hi all,
>
> Does anyone successful porting Redboot for TWRK70F120M hardware board?
> I have edited HAL of TWRK60N512 to use as TWRK70F120M. It can run but
> I don't now how to add SDRAM of K70 into linker file and use it.
> Attached files are linker file that I edited to use SDRAM, I have
> initialized PLL0 and PLL1 then DDR registers. I can access SDRAM by
> hard address (like 0x70001000). But when I load a binary file into
> SDRAM, it shown the warrning as bellow:
> <code>
> RedBoot> load -r -v -h 10.207.215.87 -m tftp -b 0x70008000 Image
> Specified address (0x70008000) is not believed to be in RAM - continue (y/n)? y
> </code>
>
> If you have any ideas about the problems, please let me know :).

You need to report this memory to RedBoot. Look for
cyg_plf_memory_segment() in twr_k60n512_misc.c (or whatever name you
have given to this file).


> If anyone have ported Redboot to K70 or successful in using SDRAM
> please share me :).
Thank you for your offer.
I am working on K70 port, everything essential seem to work (including
FPU) but I have problem initializing PLL1. I have read the errata but it
still doesn't work for me. Is there any trick?

Also when trying to initialize DDR registers the chip freezes, I guess
that it is because PLL1 is not working but maybe I need to enable
something else than DDRAM clock.
Can you send me the clock and DDR initialization sequence you are using?

Regards

Ilija


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list