[ECOS] Re: Re[ECOS] dboot hangs while loading kernel

ragavendrapec ragavendra.2007@gmail.com
Thu Jan 5 02:19:00 GMT 2012


Anyone faced this unusual situation? Plz help me it's quite urgent that I
need to get this working.

ragavendrapec wrote:
> Hi
> This is my scenario. I am using Redboot bootloader for my mips-32 board
> from Atheros. I am able to boot into the redboot prompt and flash the
> kernel and filesystem. However when i try to boot it stops after saying
> Now booting linux kernel:
>  Base address 0x80050000 Entry 0x8020cb90
>  Cmdline : console=ttyS0,115200 root=31:02 rootfstype=jffs2
> init=/sbin/init
> The kernel doesn't load after that. What could be the issue? Below is my
> fconfig -l output
> Run script at boot: true
> Boot script:
> .. fis load -d vmlinux
> .. exec
> Boot script timeout (1000ms resolution): 2
> Use BOOTP for network configuration: false
> Gateway IP address:
> Local IP address:
> Local IP address mask:
> Default server IP address:
> Console baud rate: 115200
> GDB connection port: 9000
> Force console for special debug messages: false
> Network debug at boot time: false
> The fis list output is as below
> Name              FLASH addr  Mem addr    Length      Entry point
> RedBoot           0xBF000000  0xBF000000  0x00040000  0x00000000
> vmlinux           0xBF040000  0x80060000  0x00150000  0x8020CB90
> filesystem        0xBF190000  0x80500000  0x00600000  0x00000000
> FIS directory     0xBF7E0000  0xBF7E0000  0x0000F000  0x00000000
> RedBoot config    0xBF7EF000  0xBF7EF000  0x00001000  0x00000000
> During bootup it correctly executes the boot script, however the system
> hangs and doesn't print anything after that. I am using a NOR flash and
> the linux kernel i've compiled is 2.6.31 version. I've tried even a lower
> linux version but still the same issue.
> The commands i used for flashing the bootloader, kernel and filesystem are
> load -r -b 0x80500000 redboot.rom
> fis write -f 0xbf000000 -l 0x40000 -b 0x80500000
> load -r -b 0x80500000 vmlinux.bin.gz
> fis create -b 0x80500000 -e 0x8020cb90 -r 0x80060000 -l 0x150000 -f
> 0xbf040000 vmlinux
> the 0x8020cb90 was present in the vmlinux.info file.
> load -r -b 0x80500000 <file_name>
> fis create -b 0x80500000 -l <length_of_the_file> -e 0 filesystem
> Tftp and the rest are working fine, as it says Raw file loaded after
> running the load command, and fis create also works fine.
> Kindly suggest some directions where I can find info regarding this. Plz
> help.
> Regards
> R.Vasanth Ragavendran.

View this message in context: http://old.nabble.com/Redboot-hangs-while-loading-kernel-tp33078899p33083366.html
Sent from the Sourceware - ecos-discuss mailing list archive at Nabble.com.

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list