[ECOS] HOWTO: eCos on QEMU PC emulator

Stanislav Meduna stano@meduna.org
Thu Mar 24 13:18:00 GMT 2011

On 24.03.2011 01:37, Grant Edwards wrote:

>   http://www.panix.com/~grante/eCos-on-QEMU.html

Thanks, this is an interesting work. I tried this with
VMWare and VirtualBox and I did not succeed because
of eCos calling something in the disk layer the two
do not implement

Let's see whether QEMU understand it (at least one can
fix it if it does not). Maybe you already tried it
(enabling CYGSEM_REDBOOT_DISK_IDE was enough to trigger
this in my environment)?

Out of curiosity, is there a - QEMU or not, free or not
but affordable - emulator capable of emulating
a minimal Cortex-M3 system with its Thumb-2 instruction

Part of our work is a JIT compiler and such tool would
greatly help us in debugging and (automatic) testing.


Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list