[ECOS] tcl problem when building target

Daniel Paape dpaape@amtelco.com
Tue Sep 21 18:25:00 GMT 2010


Hello,
I'm running the ecos configtool  2.11 under cygwin1.7 (for an ecos 2.1 build).  The gui build fails similarly but I have included a snippet from the command line execution (more informative).

. . .
headers finished
make -r -C services/memalloc/common/current heapgeninc.tcl
make[1]: Entering directory `/opt/voipbrd/ecos/voipboard_build/services/memalloc/common/current'
make[1]: `heapgeninc.tcl' is up to date.
make[1]: Leaving directory `/opt/voipbrd/ecos/voipboard_build/services/memalloc/common/current'
make -r -C services/memalloc/common/current heaps.cxx
make[1]: Entering directory `/opt/voipbrd/ecos/voipboard_build/services/memalloc/common/current'
XPWD=`pwd` ; cd /ecos-c/cygwin/opt/ecos/ecos-2.1/services/memalloc/common/current/src ; sh heapgen.tcl "/ecos-c/cygwin/opt/voipbrd/ecos/voipboard_install" "$XPWD"
heapgen.tcl: $'\r': command not found
DEBUG: argc=2
DEBUG: argv=/ecos-c/cygwin/opt/voipbrd/ecos/voipboard_install {/opt/voipbrd/ecos/voipboard_build/services/memalloc/commo}/current
DEBUG: builddir=C:\cygwin\opt\voipbrd\ecos\voipboard_build\services\memalloc\common\currentï??
DEBUG: installdir=C:\cygwin\opt\voipbrd\ecos\voipboard_install
DEBUG: pwd=C:/cygwin/opt/ecos/ecos-2.1/services/memalloc/common/current/src
couldn't read file "C:/cygwin/opt/voipbrd/ecos/voipboard_build/services/memalloc/common/currentï??/heapgeninc.tcl": no such file or directory
    while executing
"source [ file join $builddir heapgeninc.tcl ]"
    (file "heapgen.tcl" line 99)
make[1]: *** [heaps.cxx] Error 1
make[1]: Leaving directory `/opt/voipbrd/ecos/voipboard_build/services/memalloc/common/current'
make: *** [build] Error 
. . .

It would appear that there is a funky character at the end of the 'builddir' string.  The relevant part of the (generated - c:\cygwin\opt\ecos\myboard\service\memalloc\common\current\) makefile is the second line from below:

heaps.cxx: $(wildcard heapgeninc.tcl $(REPOSITORY)/$(PACKAGE)/src/heapgen.tcl)
        XPWD=`pwd` ; cd $(REPOSITORY)/$(PACKAGE)/src ; sh heapgen.tcl "$(PREFIX)" "$$XPWD"
        @cp heaps.hxx "$(PREFIX)"/include/pkgconf/heaps.hxx
        @chmod u+w "$(PREFIX)"/include/pkgconf/heaps.hxx

Does the XPWD='pwd' assignment generate an unlikeable carriage return?  Anyone have a fix for this?

Thanks,
Dan

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list