[ECOS]problem with recent port of lwip

Bob Brusa bob.brusa@gmail.com
Fri Sep 18 16:12:00 GMT 2009


Am 18.09.2009, 14:57 Uhr, schrieb Simon Kallweit  
<simon.kallweit@intefo.ch>:

> Bob Brusa wrote:
>> Am 17.09.2009, 13:48 Uhr, schrieb Simon Kallweit  
>> <simon.kallweit@intefo.ch>:
>>
>>> Bob Brusa wrote:
>>>> Am 17.09.2009, 09:51 Uhr, schrieb Simon Kallweit  
>>>> <simon.kallweit@intefo.ch>:
>>>>> Well, if you have configured the Sequential mode, I guess this is a  
>>>>> problem with the indexer of eclipse. Eclipse seems to not have found  
>>>>> the CYGIMP_LWIP_MODE_Sequential. I've had similar problems.
>>>>>
>>>>> The way I currently work inside eclipse is to create a C/C++ project  
>>>>> using the 'build' directory as the projectss main directory (the  
>>>>> directory where you run ecosconfig).
>>>> Do you mean "as workspace"?
>>>
>>> Create a new 'C Project' and select 'Makefile Project' -> 'Empty  
>>> Project'. Specify a project name and as the 'Location' use the build  
>>> directory where you have your ecos source tree.
>>>
>>>>> Then I add the ecos repository as a
>>>>> linked folder (I usually directly add the packages folder, as this is
>>>>  There are several ways of doing this. What is the method of your  
>>>> choice?
>>>> I understand your link in "path2ECOSroot"/packages ?
>>>
>>> Exactly. Right click on the project you just created in the 'Project  
>>> Explorer' on the left. Then select 'New' -> 'Folder'. Enter a 'Folder  
>>> name' like 'ecos' and click the 'Advanced >>' button then select the  
>>> path of your ecos repository (or it's packages subfolder).
>>>
>>> This is just the way I use eclipse with my eCos projects. I have my  
>>> sources split up in multiple ecos repositories, which I all add as  
>>> linked folders. Only drawback is that I you cannot use version control  
>>> on these folders. But I'm used to do this on the console anyway. Maybe  
>>> there are better ways of doing this?!?
>>>
>>> Simon
>>  Hi Simon
>> I did what I understood from your text - and it got messy. It seems I  
>> did not understand correctly ;-).
>>  Anyway, I reverted back to my own eclipse-methodology and also decided  
>> to go for your most recent lwip-port  
>> http://download.westlicht.ch/lwip-20090903.tar.gz (which Mandeep had  
>> mentioned). And with this it looks much more promising.
>
> Whatever works for you is fine :) I tried different schemes myself to  
> come up with what I currently use. And as I said, I'm not 100% happy  
> with it myself. But it's functional in my case.
>
>
>> Running the tcpecho.c program, I can see that the DHCP-server on our  
>> LAN recognizes the board, even assigns it an address, but somehow the  
>> thing is not really working. I have not sent any tcp-packages to the  
>> board yet, but I get a lot of timeout errors in the debug output (see  
>> attachment). Only - I do not understand why and what all this output  
>> means. Something seems to be unconfigured yet and this then causes  
>> these timeouts? How to fix that?
>
> These sys_timeout log entries are normal, as far as I know. They are  
> output when lwip checks for timeouts on blocking operations. You should  
> probably just disable "System debugging" in the debug options.
>
>>  Further: How do I send tcp-packet to port 7. Will a browser where I  
>> enter 192.168.0.10:7 send a tcp-package to port 7?
>
> Use a telnet session. You should get echo's of whatever you send to the  
> target. Note that telnet sends data when you hit the 'return' key.
>
> Simon
Hi Simon
thanks for the ultra-fast response. Meanwhile I tried and still am trying  
to understand why it does not work. I see e. g.

CYGIMP_LWIP_MODE_Sequential in lwipopts.h is undefined - although  
CYGIMP_LWIP_MODE indeed has the value Sequential. Could it be, that the  
CDL processor should generate this combined parameter from the name+value  
and it doesn't do this?

Then, when generating the library, I get warnings:
CYGIMP_LWIP_NETIF_LOOPBACK_MAX_PBUFS in netif.h and netif.c is undefined.  
Well, I found its defined in lwipopts.h I will add an import of lwipopts.h  
in netif.h and see what happens. But the above problem with the Sequential  
stuff is rather intriguing. It could cause quite a bit of "unexpected"  
code??? Please comment.

Regards Robert

-- 
Erstellt mit Operas revolutionÀrem E-Mail-Modul: http://www.opera.com/mail/

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list