[ECOS] RedBoot's load and fileio

Ross Younger wry@ecoscentric.com
Tue Sep 8 09:23:00 GMT 2009


Hi Sergei,

> Does anybody know what was a reason to suppress in RedBoot an ability
> to load files in RAM from a file on the mounted filesystem(s)? 

Support for loading from fileio is present, but hiding; I think what you
found was the old code. It really lives in fs/fileio.c, switched on by the
option CYGPKG_REDBOOT_FILEIO.

All you should need to do is add CYGPKG_IO_FILEIO to your config, and
resolve any conflicts, before you build RedBoot. Then, the syntax "load -m
fileio /some/file" is what you're looking for.

It all Just Worked for me when I tried it out a few months ago. (I was using
a YAFFS filesystem and my NAND library, but there's no reason why jffs2
shouldn't work.)


Ross

-- 
Embedded Software Engineer, eCosCentric Limited.
Barnwell House, Barnwell Drive, Cambridge CB5 8UU, UK.
Registered in England no. 4422071.                  www.ecoscentric.com

   >>>> Visit us at ESC-UK  http://www.embedded.co.uk <<<<
   >>>> Oct 7-8 on Stand 433 at FIVE ISC, Farnborough <<<<

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list