[ECOS] Re: How to set GDB Stub Options in order to run insight ?

m mariga ma_ariga@yahoo.co.jp
Mon Sep 7 09:40:00 GMT 2009


Hello,

I changed <CYGDBG_HAL_DEBUG_GDB_INCLUDE_STUBS> option's defult value from 0 
to 1,
and rebult nc_test_slave.elf and tried to run Insight again.
Then it developed like next log.
{according to Resolve conflicts Winow:
CYGBLD_ISO_FNMATCH_HEADER 
Enabled
CYGDBG_HAL_COMMON_CONTEXT_SAVE_MINIMUM            Diasabled
CYGDBG_HAL_COMMON_INTERRUPTS_SAVE_MINIMUM_CONTEXT Diasabled
CYGBLD_ISO_STRUCTTIMEVAL_HEADER                                    Enabled
}
--- new Insight's cosole window log
(gdb) set remotebaud 57600
(gdb) set remotelogfile remote-4.log
(gdb) target remote /dev/com4
Remote debugging using /dev/com4
0x000073a4 in ?? ()

(gdb) load
Loading section .text, size 0x5d58a lma 0x410000
Loading section .rodata, size 0x431e lma 0x46d58a
Loading section .data, size 0x16f8 lma 0x4718a8
Start address 0x410000, load size 405408
Transfer rate: 3 KB/sec, 63 bytes/write.

(gdb) b cyg_start
Breakpoint 1 at 0x411dda: file nc_test_slave.c, line 729.

(gdb) c
Continuing.
Network stack using 69632 bytes for misc space
                    69632 bytes for mbufs
                    139264 bytes for mbuf clusters
[cyg_net_init] Init: mbinit(0x00000000)
[cyg_net_init] Init: cyg_net_init_devs(0x00000000)
Init device 'dp83902a_eth0'
DP83902A - eeprom ESA: 00:02:cb:01:42:b9
[cyg_net_init] Init: loopattach(0x00000000)
[cyg_net_init] Init: ifinit(0x00000000)
[cyg_net_init] Init: domaininit(0x00000000)
[cyg_net_init] Init: cyg_net_add_domain(0x004728a8)
New domain internet at 0x00000000
[cyg_net_init] Init: cyg_net_add_domain(0x00472298)
New domain route at 0x00000000
[cyg_net_init] Init: call_route_init(0x00000000)
[cyg_net_init] Done

But at this point stuck to silence and no reply like before.

As I compared to previous normal RedBoot Serial log like next, I realized
it stopped at network operation.

--- previous normal RedBoot Serial log
RedBoot> go 0x410000
Network stack using 69632 bytes for misc space
                    69632 bytes for mbufs
                    139264 bytes for mbuf clusters
[cyg_net_init] Init: mbinit(0x00000000)
[cyg_net_init] Init: cyg_net_init_devs(0x00000000)
Init device 'dp83902a_eth0'
DP83902A - eeprom ESA: 00:02:cb:01:42:b9
[cyg_net_init] Init: loopattach(0x00000000)
[cyg_net_init] Init: ifinit(0x00000000)
[cyg_net_init] Init: domaininit(0x00000000)
[cyg_net_init] Init: cyg_net_add_domain(0x0046e9a0)
New domain internet at 0x00000000
[cyg_net_init] Init: cyg_net_add_domain(0x0046e398)
New domain route at 0x00000000
[cyg_net_init] Init: call_route_init(0x00000000)
[cyg_net_init] Done
Start Network Characterization - SLAVE
BOOTP[eth0] op: REPLY
       htype: Ethernet
        hlen: 6
        hops: 0
         xid: 0x0
        secs: 0
       flags: 0x0
       hw_addr: 00:02:cb:01:42:b9
     client IP: 172.16.1.200
         my IP: 172.16.1.200
     server IP: 172.16.1.1
    gateway IP: 172.16.1.1
  options:
        subnet mask: 255.255.255.0
       IP broadcast: 172.16.1.255
            gateway: 172.16.1.1
[eth_drv_ioctl] Warning: Driver can't set multi-cast mode
---

Also after changed <CYGDBG_HAL_DEBUG_GDB_INCLUDE_STUBS> to 1,I loaded 
application and run it on RedBoot,
then where it should appear "Network stack using" like above,it resulted in 
enigmatic numeric codes.

--- after changed <CYGDBG_HAL_DEBUG_GDB_INCLUDE_STUBS> to 1,RedBoot Serial 
run log
RedBoot> load -v -m xmodem -b 0x410000 nc_test_slave.srec
CEntry point: 0x00410000, address range: 0x00410000-0x00472fa0
xyzModem - CRC mode, 8909(SOH)/0(STX)/0(CAN) packets, 5 retries
RedBoot> go 0x410000
$O4E6574776F726B20737461636B207573696E6720363936333220627974657320666F72206D6973632073706163650A#0C

I concluded that according to my changing 
<CYGDBG_HAL_DEBUG_GDB_INCLUDE_STUBS> to 1,network became malfunctioning.

Anyway I could find a way out of the swamp.
I suppose by handling options properly I could run both GDB stub and network 
properly.
I strongly hope I could debug networking application using Insight.
Would you please help me ?

m mariga


-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list