[ECOS] ecos + lwip

Mandeep Sandhu mandeepsandhu.chd@gmail.com
Tue Sep 1 13:25:00 GMT 2009


On Tue, Sep 1, 2009 at 6:30 PM, Simon Kallweit<simon.kallweit@intefo.ch> wrote:
> Mandeep Sandhu wrote:
>>>
>>> Well, I had a quick look at the source of netif_add() and netif_find()
>>> and I
>>> can't really see what could potentially go wrong here. Are you sure that
>>
>> I think netif_add is not being called at all during execution, because I
>> don't
>> see any logs corresponding to that.
>
> Well, I think if the synth eth driver is not initialized properly, the netif
> will not be added to the list.
>
> But obviously it worked for lwip 1.1.1. Any ideas?

Well, something worked....and something crashed! :P

I replaced lwip_init() with cyg_lwip_sequential_init().

It's being used in all the test apps). The only difference is, the test apps
call cyg_lwip_thread_new() to create a new thread, while I call sys_thread_new()
(though this is internally calling cyg_lwip_thread_new())

With this I see the n/w interface being initialized, but the app crashes/hangs
after init-ing the interface:

...
netif_set_ipaddr: netif address being changed
netif: IP address of interface  set to 11.1.1.1
netif: netmask of interface  set to 255.255.255.0
netif: GW address of interface  set to 0.0.0.0
netif: added interface et IP addr 11.1.1.1 netmask 255.255.255.0 gw 0.0.0.0
netif: setting default interface et


After this nothing happens. I think the app's crashed here!

Any more idea's people?!

Thanks for your time.

Regards,
-mandeep


>
> Simon
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list