[ECOS] Re: RedBoot loading eCOS examples causes PC reboot

Grant Edwards grant.b.edwards@gmail.com
Sat Oct 24 13:21:00 GMT 2009


On 2009-10-24, peter_lanius@yahoo.com.au <peter_lanius@yahoo.com.au> wrote:

> I then use Hyperterminal to send the SREC file via Ymodem.
> This process seems to run ok until it is finished, when the
> suddenly PC reboots. That happens every time. No other
> applications are open. The board is connected via a
> USB-to-Serial cable and the Olimex JTAG ARM_USB_OCD is also
> connected, but OpenOCD/GDB is not running.
>
> I have tried it with the ELF file as well, same result. 
>
> What am I doing wrong

You're using Windows.

> and why does the PC reboot?

You're using Windows.  

1/2 ;)

Seriously, it's a Windows problem.  Probably a bug in one of
the of the USB-serial drivers (either the one for the
ARM_USB_OCD adapter or the one for the USB-serial cable).  Try
it without the ARM_USB_OCD plugged in.  Try it with a different
USB-serial cable (one that uses a chip from a different
vendor).

It might also be Hyperterminal. Though it's a buggy piece of
dreck, I don't think it's the cuplit in this case -- but you
could try something like Teraterm.

Or you could try using Linux...

-- 
Grant




-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list