[ECOS] RedBoot loading eCOS examples causes PC reboot

Sergei Gavrikov sergei.gavrikov@gmail.com
Sat Oct 24 12:38:00 GMT 2009


Peter writes
> Hi,
> 
> I have now successfully installed RedBoot on my Olimex LPC-E2214
> Rev_B board. I can excute RedBoot commands via the serial port using
> Hyperterminal. I then built the eCOS library for the default
> configuration using the configtool. Finally I built the eCOS example
> applications using the standard Makefile under /ecos/examples. The
> Makefile produces ELF files which are rather big (850KB) for serial
> transfer, so I used arm-eabi-objcopy to create SREC files (150KB). 
> 
> I then use RedBoot to download an application using: load -v -m
> ymodem 
> 
> I then use Hyperterminal to send the SREC file via Ymodem. This
> process seems to run ok until it is finished, when the suddenly PC
> reboots. That happens every time. No other applications are open.

Hi Peter

if you wrote, suddenly _board_ reboots, I would start to investigate
in your issue. But it seemed for me the described behavior is not eCos
(target) related thing. I'm sorry, I does not use Windows+Cygwin eCos
environment. I interact with the board via Redboot just fine on 230K
via USB-to-serial, but, under Linux. Just a guess, may be your issue
is a FTDI driver issue? Do you use UART0 to connect to the target? If
you do, it means that it is used serial-over-usb stuff (=FTDI driver
for Windows). May be some FTDI driver's issue does reboot PC? Try to
use LPC's UART1 and use a real serial DB9 connector (NO USB, NO FTDI).
On start Redboot "listens" on both serial channels and will start to
interact on that channel on which it will see the first input.

Second. You can add CYGPKG_COMPRESS (=zlib) to Redboot build and that
will let you then to upload the gzip-compressed images if you will use
RB's load command with -d (decompress) option

gzip hello

Redboot> load -m y -d
CC

Then open hello.gz in terminal program and start to upload it using
Y-modem protocol.

Third. The got images are not huge, to see/know its size, invoke

arm-eabi-size hello

and look on .code segment for a reference.

Fourth. Start to play with eCos tests using GDB or Insight. The eCos
tests are small, laconic, and well designed and they all run smoothly
under GDB. Just select in configtool: Build Tests and you will get a
lot of them for the target under tests directory.

> The board is connected via a USB-to-Serial cable and the Olimex JTAG
> ARM_USB_OCD is also connected, but OpenOCD/GDB is not running.
                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^
I'm sorry. Again, it is not eCos related too.

> I have tried it with the ELF file as well, same result. 
> 
> What am I doing wrong and why does the PC reboot?

IMO, it is something wrong with your work environment, settings, etc.
I believe in that what any terminal program can/should not reboot PC.
Well, may be just to hang it :-) or to freeze a keyboard input, but, a
rebooting..., it's very strange. Peter, what your PC is? May be it is
a Laptop with USB ports only? However, I use both and PC and DELL
Laptop without serial ports with the target having no issues with it,
but, that is Linux. I'm sorry, I have no clues anymore, but if you can
try UART1 (real serial port), try it. FYI, you can use Ethernet to
upload images on the target, but, that is off-topic just now. Try the
UART1 first.

HIH

Sergei

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list