[ECOS] Re: Error: Malloc.h :No such file or directory.

John Dallaway john@dallaway.org.uk
Fri Oct 16 09:35:00 GMT 2009

Hi Ramesh

Ramesh C Satyavaram wrote:

>  I have old ecos tool chain. I am using the ARM(ARM7DI ,StronARM) which uses
> arm-elf  for compiling. I am able to compile my application with this tool
> chain.
>   Now I decided to use the different ecos tool chain ARM (ARM7TDMI, ARM9,
> and Xscale) which is "arm-eabi" based.
> I am able to compile the ecos with the new tool chain. But when I tried to
> compile my application I am getting the following error message
> "Error:Malloc.h: No such file or directory" .
> When I tried to compile my application with the old tool chain on the same
> system , I am not getting this problem. It is only when I use the new tool
> chain I am getting this problem.

It sounds like the C pre-processor is finding a version of malloc.h in
the arm-elf toolchain when you compile your application code rather than
the version provided by the eCos package CYGPKG_MEMALLOC.

Make sure that you are using the correct compiler flags to compile your
application code. Typically, these should match the flags used by the
eCos build system when compiling eCos tests.

I hope this helps...

John Dallaway

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list