[ECOS] TAP device not created on running "ping_test"

Sergei Gavrikov sergei.gavrikov@gmail.com
Tue Jul 28 08:07:00 GMT 2009


On Tue, Jul 28, 2009 at 01:19:23PM +0530, Mandeep Sandhu wrote:
> Very strange, I get this error!
> 
> # dhcpd3 -d -f -cf /tmp/mydhcpd.conf tap0
> Internet Systems Consortium DHCP Server V3.1.1
> Copyright 2004-2008 Internet Systems Consortium.
> All rights reserved.
> For info, please visit http://www.isc.org/sw/dhcp/
> Can't open /tmp/mydhcpd.conf: Permission denied
> 
> # ls -l /tmp/mydhcpd.conf
> -rwxrwxrwx 1 mandeep mandeep 119 2009-07-28 13:09 /tmp/mydhcpd.conf
> 
> I've tried with 666 perms for /tmp/mydhcpd.conf too, but I get the same error.

Hm, may be that is security restriction...

1) For details

tail /var/log/syslog

2) Make sure there is no other dhcp server

ps -ef | grep dhc[p]

I used clean dhcp environment in the example.

3) that INTERFACES env. vaiable is needed (run command with env).

Sergei

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list