[ECOS] TAP device not created on running "ping_test"

Sergei Gavrikov sergei.gavrikov@gmail.com
Mon Jul 27 23:26:00 GMT 2009

On Mon, Jul 27, 2009 at 07:14:10PM +0530, Mandeep Sandhu wrote:
> Thanks for pointing out tunctl. But I'm not able to get ping to work...!


I did tell you about `tunctl' utility to give you manual control for
tun/tap interfaces. And as I could understand `tunctl' gave you ability
to create tap interface and check it. That was Step #1. There were and
other keywords there, e.g. dhcpd.

Some automation. You can put in /etc/network/interfaces something likes
the below

iface tap0 inet manual
  up tunctl -t tap0
  up ip l set up dev tap0
  up ip a add brd + dev tap0
  down ip l set down dev tap0
  down tunctl -d tap0

That lets you manually to bring up/down tap0 iface for synth net tests if
you want: sudo ifup tap0; sudo ifdown tap0.

And then I would suggest you to setup ecosynth networking using _dhcp_
protocol against those reserved static IP pools. You have to configure
dhcp-server to listen on tap0 iface; start the server and test that
server offers IPs from a set range using `dhclient' "tester".

On Ubuntu, (I want to belive) it possible to configure the server using

  $ sudo dpkg-reconfigure dhcp3-server

I'm sorry, but, I run/configure dhcpd manually. At the least, be sure that
/etc/default/dhcp3-server points on tap0 interface


So, before to run `ping_test' you have to get the "offered IPs" from
dhcp-server on tap0 using dhclient.



May be the below will be useful (cut from my old notes for myself :-) It
is the very minimalist sandbox (for tests purposes only). But, it worked
for me.

1) Bring up tap0 (refer to snip the above)

  $ sudo ifup tap0

2) Run DHCP server as

  $ sudo env INTERFACES="tap0" dhcpd3 -d -f -cf mydhcpd.conf tap0

# mydhcpd.conf --
default-lease-time 30;
max-lease-time 30;
subnet netmask {

3) Check that server offers IP (run dhclient in another window), when
you'll see that the server offered IP, hit ^C

  $ sudo dhclient3 -d tap0

If you have success with point 3 (only then!), rebuild synth net tests
with the defaults network settings (No static IP addresses!) with alone

    user_value 1

and run ping test as

  $ ping_test -nw -io -t my.tdf

(be sure that that dhcp server is running still)

# my.tdf --
synth_device ethernet {
    eth0 ethertap tap0

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list