[ECOS] hello world app SEG faults with Linux synth target

Mandeep Sandhu mandeepsandhu.chd@gmail.com
Wed Jul 22 14:05:00 GMT 2009


> Let me try again by starting afresh, from scratch for everything, using the
> i386-elf toolchain. Let me get back here then.

It worked! :)

I did a fresh start, i.e install ecos with i386-elf binaries.

This is what I did (on my Ubuntu 9.04):

$ mkdir linux-synth
$ cd linux-synth
$ ecosconfig new linux
$ ecosconfig add lwip_eth
$ ecosconfig add libc_stdio
$ ecosconfig tree

edit ecos.ecc
set CYGBLD_GLOBAL_COMMAND_PREFIX to "i386-elf"
change CYGBLD_GLOBAL_CFLAGS, append -fno-stack-protector

$ make
$ sed -i 's/ libgcc_eh.a//' install/lib/target.ld
$ make tests
$ ./install/tests/language/c/libc/stdio/v3_0/tests/stdiooutput

NOTE: I did not have to give the "-io" option.

Sergei, John, thanks a lot for your help.

Regards,
-mandeep

>
> As an aside, I tried doing a "Tools -> Run Tests" in the GUI...
>
> It shows "exec error - No such file or directory" in the output window.
>
> Thanks,
> -mandeep
>
>>
>> Sergei
>>
>

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list