[ECOS] Re: h8300 cannot find libgcc.a

m mariga ma_ariga@yahoo.co.jp
Wed Jul 22 12:28:00 GMT 2009


Hello,John,and everybody,

Thank you John for your reply.
I think I became a little bit knowledgeable.

> Note that most of the eCos community is using GCC 4.3.2 so you may well
> discover a few compiler warnings and other issues if you build with GCC
> 4.4.0.

First I tried to use GCC 4.3.2 for installing h8300 ToolChain.
But it resulted Segmentation error at configureration.

-- gcc4.3.2 confiure errror
/tmp/build/build_gcc/./gcc/xgcc -B/tmp/build/build_gcc/./gcc/ -nostdinc -B/tmp/build/build_gcc/h8300-elf/h8300s/normal/newlib/
 -isystem /tmp/build/build_gcc/h8300-elf/h8300s/normal/newlib/targ-include
 -isystem
/src/gcc-4.3.2/newlib/libc/include -B/gnutools/h8300-elf/bin/ -B/gnutools/h8300-elf/lib/
 -isystem /gnutools/h8300-elf/include -isystem
/gnutools/h8300-elf/sys-include  -ms -mn -DPACKAGE_NAME
=\"newlib\" -DPACKAGE_TARNAME=\"newlib\" -DPACKAGE_VERSION=\"1.16.0\" -DPACKAGE_STRING=\"newlib\
1.16.0\" -DPACKAGE_BUGREPORT=\"\" -I. -I/src/gcc-4.3.2/newlib/libm/math -I/src/gcc-4.3.2/newlib/libm/ma
th/../common -O2 -DSMALL_DTOA -DSMALL_MEMORY -fno-builtin      -O2 -g -g -O2
    -ms -mn -c -o lib_a-wf_lgamma.o `test -f 'wf_lgamma.c' || echo
'/src/gcc-4.3.2/newlib/libm/math/'`wf_lgamma.c
In file included from /src/gcc-4.3.2/newlib/libc/include/math.h:5,
                 from /src/gcc-4.3.2/newlib/libm/math/../common/fdlibm.h:15,
                 from /src/gcc-4.3.2/newlib/libm/math/wf_lgamma.c:17:
/src/gcc-4.3.2/newlib/libc/include/sys/reent.h:95: internal compiler error:
Segmentation fault
Please submit a full bug report,
---

I asked to gcc mailing list but could not get reply.
I tried to use GCC 4.4.0 and there was no error,so I am determined to use 
GCC 4.4.0.

>> /opt/ecos/ecos-3.0/packages/language/c/libm/v3_0/src/mathincl/fdlibm.h:78:3:
>>
>> error: #error IEEE-style 64-bit doubles are required to use the math 
>> library
>
> You compiler is providing 32-bit doubles. You need 64-bit doubles in
> order to build the eCos math library. There's a patch available for the
> KPIT v0401 tools which may help:
>
>  http://www.cetoni.de/develop/develop_ecosh8s_en.html#a_broschueren

I downloaded the patch file but it is for use of GCC 3.3 source.
I also get the same purpose patch file that is for GCC 3.3.2 source.
I append it in zip file.

I studied it and learned that I could not use it for GCC 4.4.0 source per 
se.
I searched Internet for newer patch corresponding to GCC 4.4.0 or at least 
to GCC 4.3.2 but could not find one.
Couldn't it be possible that you send me the newer patch corresponding to 
GCC 4.4.0 or at least to GCC 4.3.2 ?

If I could not get it I must study the old patch and change the GCC 4.4.0 
source manually.
It is hard, isn't it, because there are too differences between GCC 3.3.2 
and GCC 4.4.0.

Do you have any better idea ?

m mariga
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gcc_diff_new_patch.gz
Type: application/x-gzip
Size: 3058 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/ecos-discuss/attachments/20090722/5be41230/attachment.bin>
-------------- next part --------------
-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss


More information about the Ecos-discuss mailing list