[ECOS] Re: Problems initializing eth0 interface

John Dallaway john@dallaway.org.uk
Wed Jul 15 14:13:00 GMT 2009


Hi Bruno

Bruno Ricci wrote:

> Thank you John, that worked like a charm :)
> 
> Thanks everyone

Good to hear this resolved the problem you were seeing.

What was the PCI VendorID/DeviceID for your RTL8139 ethernet hardware?

John Dallaway


--- Original Message ---
> On Wed, Jul 15, 2009 at 12:50 PM, John Dallaway<john@dallaway.org.uk> wrote:
> 
>> Hi Bruno
>>
>> Bruno Ricci wrote:
>>
>>> I tried the same configuration with RTL8139 chip and without removing
>>> any package (I managed to have a pc with that chip) with no luck. Here
>>> some screenshots:
>>>
>>> http://files.getdropbox.com/u/1493094/ecos1.jpg
>>> http://files.getdropbox.com/u/1493094/ecos2.jpg
>>>
>>> Notice that my program only initializes the network card, and that
>>> there's a 20 sec sleep between the two screenshots. I tried to set a
>>> static IP, but I keep on having that SIOCIFADDR error.
>> I assume you have switched to the eCos "pc_rltk8139" target.
>>
>> The reported hardware address (ff:ff:ff:ff:ff:ff) is bogus which
>> suggests that eCos is failing to interrogate your ethernet hardware
>> correctly. Try disabling the ethernet hardware in your PC's BIOS and see
>> if the behaviour is the same. If it is, perhaps your ethernet hardware
>> is reporting a PCI vendorID/deviceID pair which is not known to the eCos
>> driver? Check the known_8139_aliases[] array in the driver and extend it
>> if necessary.
>>
>> I hope this helps...
>>
>> John Dallaway

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list