[ECOS] Re: Problems initializing eth0 interface

Tarmo Kuuse tarmo.kuuse@mail.ee
Wed Jul 15 10:27:00 GMT 2009

Bruno Ricci wrote:
> I tried the same configuration with RTL8139 chip and without removing
> any package (I managed to have a pc with that chip) with no luck. Here
> some screenshots:
> http://files.getdropbox.com/u/1493094/ecos1.jpg
> http://files.getdropbox.com/u/1493094/ecos2.jpg
> Notice that my program only initializes the network card, and that
> there's a 20 sec sleep between the two screenshots. I tried to set a
> static IP, but I keep on having that SIOCIFADDR error.

The second screenshot shows your hardware address to be 
FF:FF:FF:FF:FF:FF. This is the Ethernet broadcast address and it's not a 
good idea to use it as your MAC.

Try setting a valid MAC address. The first byte should be 0x00 and the 
others you are free to choose. Eg 00:ab:cd:ef:01:23 would be reasonaby 
safe. Make sure the address doesn't conflict with anything else in your 

If you have RedBoot, change the MAC address using fconfig. If not, then 
the MAC address can be hardcoded via eCos configuration tool (look under 
"I/O sub-system", "Common ethernet support", "Your ethernet driver").

Kind regards,
Tarmo Kuuse

Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

More information about the Ecos-discuss mailing list