[ECOS] Re: Running gdb in Cygwin

John Dallaway john@dallaway.org.uk
Fri Jul 10 15:58:00 GMT 2009


Graham

John Dallaway wrote:

> Graham Labdon wrote:
> 
>> When installing Cygwin I need to add gcc package
> 
> Yes, but there are several other Cygwin packages that you also need to
> add, as described at:
> 
>   http://ecos.sourceware.org/cygwin.html
> 
> Cygwin-hosted GNU tools have been known to fail silently when required
> DLLs are not installed.

arm-eabi-gdb.exe requires the following Cygwin DLLs:

  C:\cygwin\bin\cygwin1.dll
  C:\cygwin\bin\cygexpat-1.dll
  C:\cygwin\bin\cygiconv-2.dll
  C:\cygwin\bin\cygintl-8.dll
  C:\cygwin\bin\cygncurses-8.dll
  C:\cygwin\bin\cygz.dll

So if any of these DLLs don't exist in your own Cygwin installation,
that could explain the problem you are observing. If you have installed
all the packages listed on the above page and still don't have all the
DLLs you need, please let me know which one(s) are missing in your
installation.

John Dallaway

-- 
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss



More information about the Ecos-discuss mailing list